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Knowledge Advanced and Oracle Service Cloud User Account Synchronization
Answer ID 10300   |   Last Review Date 07/24/2019

Why are the Staff Accounts in Oracle Service Cloud not showing up in Authoring?

Environment:

Oracle Service Cloud Knowledge Advanced, 19A and earlier

Issue:

I am unable to see some Console Users when reviewing the "Authoring > Users > Console User" page while using an Administrator account.

Resolution:

This can be resolved by having the user in question access Authoring or open the Knowledge tool (via enabling the tool window or clicking the ribbon button on an incident or chat), as their profile and account will then be created or updated in KA. The users Staff Account in the Agent Console is used to create the Console User account in Authoring.

Cause:

KA relies on a real-time account shadowing process that checks if a logged in user has a Staff Account in OSvC. Any changes made to a Staff Account will not synchronize to the Console User in Authoring until the user attempts to access KA again and kicks off the account shadowing process.

As this process is only run when a user accesses KA content, it can cause some confusion when no users appear in a new KA implementation, but there are lots of Staff Accounts with Authoring access.

Notes:

For additional information, refer to the 'Managing Users' section in the online documentation for the version your site is currently running. To access Oracle Service Cloud manuals and documentation online, refer to the Answer ID 8156: Documentation for Oracle Service Cloud Knowledge Advanced.