Skip Navigation
Expand
Unable to upload a masking XML file in Cobrowse
Answer ID 9094   |   Last Review Date 12/19/2018

Why do I receive the message "Uploaded file should contain at least one value tag" when attempting to upload a masking XML configuration file in myLiveLOOK account?

Environment:

Cobrowse

Resolution:

The message "Uploaded file should contain at least one value tag" is generated when attempting to upload a masking configuration XML file where the first line in the file is an XML comment designated by an opening <? and closing ?>.

An example of an common XML comment seen in these files is <?xml version="1.0" encoding="UTF-16"?>. 

To resolve the issue, remove the XML comment line, save the file, and upload it once more.

Notes:

If the masking file has been copied or downloaded from a source where the "-" symbols precedes any of the <tags>, these will also need to be removed before saving and uploading the XML file.

For example, the following was copied from a masking file opened from within myLiveLOOK.  The highlighted texts need to be removed before attempting to upload XML file again:

<?xml version="1.0" encoding="UTF-16"?>
- <configuration>
    - <siteCode id="<SITE_ID>" currentState="Active">
         - <module id="LTB" scope="SITE">
              - <param id="ltb_urls">
                    <value text="http*://*.livelook.com/*?*#*" title="" seqId="0"/>
               </param>
             - <param id="ltb_urls_exc">
                    <value text="http*://*.google.com/*#*" title="" seqId="0"/>
               </param>
          </module>
     </siteCode>
</configuration>

 

Available Languages for this Answer:

Notify Me
The page will refresh upon submission. Any pending input will be lost.