Skip Navigation
Expand
Custom Processes must have matching version information between the annotation and included Connect library
Answer ID 8655   |   Last Review Date 10/29/2020

Does the version information within the comment/annotation section of a Custom Process (CPM) script affect processing?

Environment:

Process Designer, Custom Process Model (CPM) / Service Process Model (SPM)
All product versions

Resolution:

The version information within the comment/annotation section of a Custom Process (CPM) script does affect processing. The following is an example of this required section of a CPM script customization:

/**
* CPMObjectEventHandler: NameOfScript
* Package: RN
* Objects: Incident
* Actions: Create
* Version: 1.4
* Purpose: The documented purpose of the script
 */

This is an example of a matching connect library to include to match the above example:

use \RightNow\Connect\v1_4 as Connect;
use \RightNow\CPM\v1 as RNCPM;

Notice the 'Version: 1.4' matches the version indicated in 'use \RightNow\Connect\v1_4 as Connect'.

Further, the version used in all CPHP code must match, and this holds true for all external scripts used by a CPM customization. Failing to do so in a CPM customization may work in some cases but not others, or may result in unexpected errors upon site version upgrades or patches.

Available Languages for this Answer:

Notify Me
The page will refresh upon submission. Any pending input will be lost.