Skip Navigation
Expand
Support has ended for Windows 7 and some versions of Microsoft's .NET Framework
Answer ID 8253   |   Last Review Date 02/03/2020

How will the announcement from Microsoft regarding support ending for Windows 7 and  some .Net versions affect the Oracle/RightNow application?

Environment:

All Supported .NET versions of Service Cloud Console (OSvC)

Issue:

Support by Microsoft is ending for Windows 7 and some versions of Microsoft .NET framework. See Notes below!

In keeping with general Oracle support policies, Oracle B2C Service Technical Support cannot provide support of the Service Cloud console or End User pages with an Operating System, Browser, applications or application components after support by the OEM has ended. There are no exceptions to this policy. 

NOTES

As of January 14, 2020 Support ends for Windows 7. Oracle B2C Service Technical Support recommends that agent desktop users upgrade to Windows 10 as soon as possible.

As of January 2019, Support for .NET version of .NET 4.7 and older will be ending soon. For details on this please see .NET Framework Support Lifecycle Policy FAQ.

Oracle B2C Service Technical Support recommends that agent desktop users upgrade to .NET 4.7.1 as soon as possible.

As of January 12, 2016 Microsoft discontinued support for all but the most current versions of the .NET Framework for a Windows Operating System. For details on this please see .NET Framework Support Lifecycle Policy FAQ.

Please check with Microsoft on the changes to their support policies and or supported Operating Systems, Browsers, applications or application components. 

Resolution:

Oracle B2C Service strongly recommends that all customers upgrade to the latest version of .NET compatible with the Operating System, and supported by Microsoft.

Customers requesting support from Oracle B2C Service Technical Support will be required to be running the latest supported version of .NET.

Important notes on B2C Service and .NET versions

  • Starting in 18D: Users see a warning dialog reminding them to update .NET when logging in to the Service Cloud agent desktop.
  • Starting in 19A: Oracle dropped support for .NET versions less than 4.7.1.
  • Starting in 19B: It will not be possible to login to the agent desktop on .NET versions older than 4.7.1.

Because .NET 4.7.1 is supported in Service Cloud versions 18A and newer, we recommend that affected agents upgrade .NET as soon as possible.

Note that .NET requirements do not apply to agents using the Browser User Interface.

NOTE: The warning message seen at login regarding updating .NET cannot be removed from the login screen except by updating .NET.


See also:

https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/versions-and-dependencies

https://support.microsoft.com/en-us/help/13853/windows-lifecycle-fact-sheet

Available Languages for this Answer:

Notify Me
The page will refresh upon submission. Any pending input will be lost.