Skip Navigation
Expand
Non-compatible upgrade of SOAP API
Answer ID 8250   |   Last Review Date 01/13/2019

Does an upgrade of our site require an update to our SOAP customizations?

Environment:

Connect Web Services for SOAP (CWS) API

Resolution:

The Connect Web Services for SOAP (CWS) API is a managed framework, meaning code using it should not need to be updated to support a site upgrade in general. However, all managed frameworks are versioned and each version has a two year time-frame before it is deprecated. Customized code should therefore be updated regularly to meet this two year time frame between when the new framework version comes out with a new product release, and the following deprecation of that version two years from that general availability product release. For further information on Oracle Service Cloud deprecations please refer to the following answer:

Answer ID 5974: Oracle Service Cloud Deprecations

Further, in the case of CWS it is best to use typed wsdl URLs when developing customized code - so it is clear what version of the managed framework the customization is intended to utilize. For information on how to format a versioned wsdl URL please refer to the following:

Answer ID 6741: Correct Syntax for connecting through the wsdl

Available Languages for this Answer:

Notify Me
The page will refresh upon submission. Any pending input will be lost.