Skip Navigation
Expand
Escalation rule not firing
Answer ID 5377   |   Last Review Date 12/18/2018

Why is my escalation rule not firing?

Environment:

Configuration, Incident rules
Oracle Service Cloud, Business Rules

Issue:

I have set up an escalation rule which checks an incident's status, and after a certain amount of time elapses, is supposed to change the Escalation Level so that the incident can move to the next rule which closes the incident.  However, when I check the rule log, it appears that rules have stopped processing for the incident and I have to manually close the incident. 

Resolution:

In any rule or function that looks at the incident's status, it is important to remember that rules will stop being processed on an incident if its status is set to a "Solved" state. 

To check this, go to  Configuration > Application appearance > Customizable Menus > Incident Statuses.  Find the incident status you are checking for, and be certain that the type is either "Unresolved" or "Waiting".  If it is a "Solved" type, then the incident is considered closed by the system and rules will not continue processing.

For more information, refer to the following published answers:
Answer ID 1231: Testing escalation rules
Answer ID 5844: Incidents are not escalating as expected
Answer ID 1873: Using the Rule Log to troubleshoot rules

 

 

Available Languages for this Answer:

Notify Me
The page will refresh upon submission. Any pending input will be lost.