Skip Navigation
Expand
Survey responses disappeared after a few days
Answer ID 10123   |   Last Review Date 10/28/2018

Why have certain responses to our surveys disappeared from reports?

Environment:

Surveys, Feedback
Oracle Service Cloud

Issue:

We have a custom report used for viewing survey responses. We have found that certain responses disappear after a few days. Why does that happen?

Resolution:

If you are exposing survey question responses that are marked as proofs (question_sessions.proof_mode), these are deleted every 7 days by the agedatabase utility.
 
Survey question responses that are marked as proofs include:
  1. Those that are completed from a proof initiated from the console (any open survey record > Proofing tab > Send Proof Message... button). These kind of responses are, by design, considered to be useful only for a short period of time, while you are setting up your survey and checking how data shows up in reporting.
     
  2. Those that have a user-agent matched in configuration setting SEC_SPIDER_USER_AGENT. These responses are recorded here also for reference, they allow you to evaluate if the custom spider agents you included are filtering only what you were expecting.
This is a hard-coded behavior, and cannot be configured. 
 
For more information on accessing the Configuration Editor and editing settings, refer to Answer ID 1960: Editing Configuration Settings.

Available Languages for this Answer:

Notify Me
The page will refresh upon submission. Any pending input will be lost.